Installation des rôles serveur Web prérequis

L'installation de Devolutions Server est compatible avec Windows Server 2016, 2019 et 2022.

En tant qu'application Web, Devolutions Server nécessite le gestionnaire IIS, le module de réécriture d'URL, l'Application Request Routing, ASP.Net 6.0 et des rôles Web spécifiques sur la machine sur laquelle il sera hébergé.

Il est possible d'installer ces prérequis, le gestionnaire IIS et le module de réécriture d'URL sont inclus dans la Console de Devolutions Server ou via un script PowerShell existant fourni avec Remote Desktop Manager Team - Édition Windows.

Assistant Ajout de rôles et de fonctionnalités
Assistant Ajout de rôles et de fonctionnalités

L'installation des prérequis à partir de la Console de Devolutions Server ou du script PowerShell nécessite un accès internet pour télécharger le module de réécriture d'URL, l'Application Request Routing et ASP.Net 6.0.

Étapes

Voici les deux méthodes disponibles pour installer les prérequis :

  1. Console de Devolutions Server.

    1. Ouvrir la Console de Devolutions Server.

    2. Sélectionner le menu Soutien et cliquer le bouton Diagnostic d'IIS.

      ServerOp8153

    3. Cliquer sur le bouton Installer les pré-requis pour exécuter le script PowerShell.

    Cette fenêtre apparaitra seulement si un prérequis est manquant lors d'une nouvelle installation ou d'une mise à jour.

    ServerOp8154

  2. Ligne de commande PowerShell.

    1. Exécuter Windows PowerShell avec des privilèges élevés.

    2. Modifier l'emplacement vers le sous-dossier Scripts qui se trouve dans le dossier d'installation de la Console de Devolutions Server (C:\Program Files (x86)\Devolutions\Devolutions Server Console\Scripts).

      Emplacement du script PowerShell
      Emplacement du script PowerShell

    3. Exécuter le script DVLS-Prerequisites.ps1.

    4. Le script installera les rôles Web manquants et les composants suivants :

      • le module de réécriture d'URL IIS.
      • l'Application Request Routing Module IIS.
      • le module IIS APS.Net Core (.Net 6.0).
        ServerOp4038