Problème lors de l'utilisation du module d'extension Workspace avec Localhost et HTTPS

Il est peu probable que le module d'extension Workspace fonctionne un jour avec HTTPS. Voici quelques-unes des raisons :

  1. Il est nécessaire de générer un certificat, ce qui entraîne de nombreux problèmes de communication avec les Certificats pour localhost des applications natives.
  2. Même si un certificat est généré, une erreur de type ::ERR_CERT_AUTHORITY_INVALID devrait apparaître puisque le certificat est auto signé et que Chrome localhost bloque de telles requêtes.
  3. Il sera nécessaire d’ Autoriser les certificats invalides pour les ressources chargées à partir de localhost dans Chrome, mais cette méthode n’est pas recommandé chrome://flags/#allow-insecure-localhost.

La seule vraie manière de contourner ce problème est d’utiliser la messagerie native : Module d'extension Workspace via la messagerie native.